Apache 2.2 < 2.2.17 Multiple Vulnerabilities

High Log Correlation Engine Plugin ID 800577


The remote web server is vulnerable to multiple attack vectors.


Versions of Apache 2.2 earlier than 2.2.17 are potentially affected by multiple vulnerabilities :

- Errors exist in the bundled expat library that may allow an attacker to crash the server when a buffer is over-read when parsing an XML document. (CVE-2009-3720 and CVE-2009-3560)

- An error exists in the 'apr_brigade_split_line' function in the bundled APR-util library. Carefully timed bytes in requests result in gradual memory increases leading to a denial of service. (CVE-2010-1623)
IAVA Reference : 2012-A-0020
STIG Finding Severity : Category I


Either ensure the affected module is not in use or upgrade to Apache version 2.2.17 or later.

See Also



Plugin Details

Severity: High

ID: 800577

Family: Web Servers

Published: 2013/05/07

Nessus ID: 50070

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2010/10/19

Vulnerability Publication Date: 2009/01/17

Reference Information

CVE: CVE-2009-3560, CVE-2009-3720, CVE-2010-1623

BID: 37203, 36097, 43673