Apache < 2.2.9 Multiple Vulnerabilities

Medium Log Correlation Engine Plugin ID 800558

Synopsis

The remote web server may be affected by several issues.

Description

According to its banner, the version of Apache 2.2 installed on the remote host is older than 2.2.9. Such versions may be affected by several issues, including :

- Improper handling of excessive forwarded interim responses may cause denial of service conditions in mod_proxy_http (CVE-2008-2364).
- A cross-site request forgery vulnerability in the balancer-manager interface of mod_proxy_balancer (CVE-2007-6420).
- An issue exists in the handling of the 'Options' and 'AllowOverride' directives (CVE-2009-1195).

Note that the remote web server may not actually be affected by these vulnerabilities.

Solution

Either ensure that the affected modules are not in use or upgrade to Apache version 2.2.9 or higher.

See Also

http://www.apache.org/dist/httpd/CHANGES_2.2

http://httpd.apache.org/security/vulnerabilities_22.html

http://www.securityfocus.com/bid/29653

Plugin Details

Severity: Medium

ID: 800558

File Name: 800558.prm

Family: Web Servers

Nessus ID: 33477

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Reference Information

CVE: CVE-2007-6420, CVE-2007-6421, CVE-2007-6422, CVE-2007-6423, CVE-2008-2364, CVE-2009-1195

BID: 35115, 27236, 29653