FreeBSD : FreeBSD -- shell injection vulnerability in patch(1) (0d090952-600a-11e6-a6c3-14dae9d210b8)

This script is Copyright (C) 2016-2017 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing a security-related update.

Description :

Due to insufficient sanitization of the input patch stream, it is
possible for a patch file to cause patch(1) to pass certain ed(1)
scripts to the ed(1) editor, which would run commands. Impact : This
issue could be exploited to execute arbitrary commands as the user
invoking patch(1) against a specially crafted patch file, which could
be leveraged to obtain elevated privileges.

See also :

http://www.nessus.org/u?9f42d79a

Solution :

Update the affected package.

Risk factor :

High

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 92892 ()

Bugtraq ID:

CVE ID: CVE-2015-1418

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now