Mac OS X : Apple Safari < 9.0.3 Multiple Vulnerabilities

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote host has a web browser installed that is affected by
multiple vulnerabilities.

Description :

The version of Apple Safari installed on the remote Mac OS X host is
prior to 9.0.3. It is, therefore, affected by the following
vulnerabilities :

- Multiple memory corruption vulnerabilities exist in
WebKit due to improper validation of user-supplied
input. A remote attacker, via a specially crafted
website, can exploit these issues to execute arbitrary
code or cause a denial of service. (CVE-2016-1723,
CVE-2016-1724, CVE-2016-1725, CVE-2016-1726,
CVE-2016-1727)

- A flaw exists in the Cascading Style Sheets (CSS)
implementation in WebKit CSS when handling the
'a:visited button' CSS selector while evaluating the
height of the containing element. A remote attacker
can exploit this, via a crafted website, to obtain
sensitive browser history information. (CVE-2016-1728)

See also :

https://support.apple.com/en-us/HT205730
http://www.nessus.org/u?c7e0375f

Solution :

Upgrade to Apple Safari version 9.0.3 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.5
(CVSS2#E:U/RL:OF/RC:UR)
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 88597 ()

Bugtraq ID: 81263

CVE ID: CVE-2016-1723
CVE-2016-1724
CVE-2016-1725
CVE-2016-1726
CVE-2016-1727
CVE-2016-1728

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now