Google Chrome < 47.0.2526.80 Multiple Vulnerabilities

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a web browser that is affected by
multiple vulnerabilities.

Description :

The version of Google Chrome installed on the remote Windows host is
prior to 47.0.2526.80. It is, therefore, affected by multiple
vulnerabilities :

- A type confusion error exists related to extensions that
allows an attacker to have an unspecified impact.
(CVE-2015-6788)

- A use-after-free error exists in Blink that is triggered
when handling updates. An unauthenticated, remote
attacker can exploit this to dereference already freed
memory, resulting in the execution of arbitrary code.
(CVE-2015-6789)

- An unspecified escaping issue exists in saved pages.
(CVE-2015-6790)

- Multiple unspecified vulnerabilities exist that an
attacker can exploit to have an unspecified impact.
(CVE-2015-6791)

- Multiple heap buffer overflow conditions exist that
allow an attacker to execute arbitrary code.
(CVE-2015-8438, CVE-2015-8446)

- Multiple memory corruption issues exist that allow an
attacker to execute arbitrary code. (CVE-2015-8045,
CVE-2015-8047, CVE-2015-8060, CVE-2015-8408,
CVE-2015-8416, CVE-2015-8417, CVE-2015-8418,
CVE-2015-8419, CVE-2015-8443, CVE-2015-8444,
CVE-2015-8451, CVE-2015-8455)

- Multiple security bypass vulnerabilities exist that
allow an attacker to write arbitrary data to the file
system under user permissions. (CVE-2015-8453,
CVE-2015-8440, CVE-2015-8409)

- A stack buffer overflow condition exists that allows an
attacker to execute arbitrary code. (CVE-2015-8407,
CVE-2015-8457)

- A type confusion error exists that allows an attacker to
execute arbitrary code. (CVE-2015-8439, CVE-2015-8456)

- An integer overflow condition exists that allows an
attacker to execute arbitrary code. (CVE-2015-8445)

- A buffer overflow condition exists that allows an
attacker to execute arbitrary code. (CVE-2015-8415)

- Multiple use-after-free errors exist that allow an
attacker to execute arbitrary code. (CVE-2015-8048,
CVE-2015-8049, CVE-2015-8050, CVE-2015-8055,
CVE-2015-8056, CVE-2015-8057, CVE-2015-8058,
CVE-2015-8059, CVE-2015-8061, CVE-2015-8062,
CVE-2015-8063, CVE-2015-8064, CVE-2015-8065,
CVE-2015-8066, CVE-2015-8067, CVE-2015-8068,
CVE-2015-8069, CVE-2015-8070, CVE-2015-8071,
CVE-2015-8401, CVE-2015-8402, CVE-2015-8403,
CVE-2015-8404, CVE-2015-8405, CVE-2015-8406,
CVE-2015-8410, CVE-2015-8411, CVE-2015-8412,
CVE-2015-8413, CVE-2015-8414, CVE-2015-8420,
CVE-2015-8421, CVE-2015-8422, CVE-2015-8423,
CVE-2015-8424, CVE-2015-8425, CVE-2015-8426,
CVE-2015-8427, CVE-2015-8428, CVE-2015-8429,
CVE-2015-8430, CVE-2015-8431, CVE-2015-8432,
CVE-2015-8433, CVE-2015-8434, CVE-2015-8435,
CVE-2015-8436, CVE-2015-8437, CVE-2015-8441,
CVE-2015-8442, CVE-2015-8447, CVE-2015-8448,
CVE-2015-8449, CVE-2015-8450, CVE-2015-8452,
CVE-2015-8454)

- A flaw exists in Google V8 in serialize.cc that is
triggered when handling alignment for deferred objects.
An attacker can exploit this to have an unspecified
impact. (CVE-2015-8548)

See also :

http://www.nessus.org/u?a6b6361f

Solution :

Upgrade to Google Chrome 47.0.2526.80 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true