Squid 3.2 < 3.5.4 Incorrect X509 Server Certificate Validation Vulnerability

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote proxy server may be affected by a certificate validation
vulnerability.

Description :

According to its banner, the version of Squid running on the remote
host is 3.2 prior to 3.2.14 / 3.3.14 / 3.4.13 / 3.5.4. It is,
therefore, potentially affected by a flaw related to certificate
validation due to the server hostname not being verified as matching a
the domain name in the certificate Subject's Common Name (CN) or the
SubjectAltName fields. A man-in-the-middle attacker, using a crafted
certificate, can utilize this to spoof a TLS/SSL server, thus allowing
the disclosure or manipulation of intercepted data. Note that this
flaw is exploitable only if Squid is configured to perform SSL Bumping
with the 'client-first' or 'bump' mode of operation.

Note that Nessus has not tested for this issue but has instead relied
only on the application's self-reported version number. The patch
released to address the issue does not update the version in the
banner. If the patch has been applied properly, and the service has
been restarted, consider this to be a false positive.

See also :

http://www.squid-cache.org/Advisories/
http://www.squid-cache.org/Advisories/SQUID-2015_1.txt
http://www.nessus.org/u?8ef2aa9b

Solution :

Upgrade to Squid versions 3.2.14 / 3.3.14 / 3.4.13 / 3.5.4, or apply
the vendor-supplied patch.

Risk factor :

Medium / CVSS Base Score : 5.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N)
CVSS Temporal Score : 5.0
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Firewalls

Nessus Plugin ID: 83529 ()

Bugtraq ID: 74438

CVE ID: CVE-2015-3455

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now