openSUSE Security Update : DirectFB (openSUSE-2015-340)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

DirectFB was updated to fix two security issues.

The following vulnerabilities were fixed :

- CVE-2014-2977: Multiple integer signedness errors could
allow remote attackers to cause a denial of service
(crash) and possibly execute arbitrary code via the
Voodoo interface, which triggers a stack-based buffer
overflow.

- CVE-2014-2978: Remote attackers could cause a denial of
service (crash) and possibly execute arbitrary code via
the Voodoo interface, which triggers an out-of-bounds
write.

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=878345
https://bugzilla.opensuse.org/show_bug.cgi?id=878349

Solution :

Update the affected DirectFB packages.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: SuSE Local Security Checks

Nessus Plugin ID: 83171 ()

Bugtraq ID:

CVE ID: CVE-2014-2977
CVE-2014-2978

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now