CVE-2014-2977

HIGH

Description

Multiple integer signedness errors in the Dispatch_Write function in proxy/dispatcher/idirectfbsurface_dispatcher.c in DirectFB 1.4.13 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via the Voodoo interface, which triggers a stack-based buffer overflow.

References

http://advisories.mageia.org/MGASA-2015-0176.html

http://lists.opensuse.org/opensuse-security-announce/2015-04/msg00019.html

http://lists.opensuse.org/opensuse-security-announce/2015-05/msg00003.html

http://mail.directfb.org/pipermail/directfb-dev/2014-March/006805.html

http://secunia.com/advisories/58448

http://www.mandriva.com/security/advisories?name=MDVSA-2015:223

http://www.openwall.com/lists/oss-security/2014/05/15/9

https://security.gentoo.org/glsa/201701-55

Details

Source: MITRE

Published: 2014-06-11

Updated: 2018-10-30

Type: CWE-189

Risk Information

CVSS v2.0

Base Score: 10

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 10

Severity: HIGH