IBM WebSphere Application Server 8.0 < Fix Pack 10 Multiple Vulnerabilities (POODLE)

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote application server is affected by multiple vulnerabilities.

Description :

The remote host is running IBM WebSphere Application Server version
8.0 prior to Fix Pack 10. It is, therefore, affected by the following
vulnerabilities :

- Multiple errors exist related to the included IBM HTTP
server that can allow remote code execution or denial
of service. (CVE-2013-5704, CVE-2014-0118,
CVE-2014-0226, CVE-2014-0231 / PI22070)

- An error exists related to the implementation of the
Elliptic Curve Digital Signature Algorithm (ECDSA) that
could allow nonce disclosure via the 'FLUSH+RELOAD'
cache side-channel attack. (CVE-2014-0076 / PI19700)

- An unspecified error exists related to HTTP headers that
can allow information disclosure. (CVE-2014-3021 /
PI08268)

- An unspecified error caused by improper account creation
with the Virtual Member Manager SPI Admin Task
'addFileRegistryAccount' can allow remote attackers to
bypass security restrictions. (CVE-2014-3070 / PI16765)

- An information disclosure vulnerability exists due to a
failure to restrict access to resources located within
the web application. A remote attacker can exploit this
to obtain configuration data and other sensitive
information. (CVE-2014-3083 / PI17768, PI30579 )

- A man-in-the-middle (MitM) information disclosure
vulnerability known as POODLE. The vulnerability is due
to the way SSL 3.0 handles padding bytes when decrypting
messages encrypted using block ciphers in cipher block
chaining (CBC) mode. MitM attackers can decrypt a
selected byte of a cipher text in as few as 256 tries if
they are able to force a victim application to
repeatedly send the same data over newly created SSL 3.0
connections. (CVE-2014-3566 / PI28435, PI28436, PI28437)

- An unspecified flaw in the Load Balancer for IPv4
Dispatcher component allows a remote attacker to cause
a denial of service. (CVE-2014-4764 / PI21189)

- An unspecified input validation error exists related to
the administrative console that can allow cross-site
scripting and cross-site request forgery attacks.
(CVE-2014-4770, CVE-2014-4816 / PI23055)

- An error exists related to the Communications Enabled
Applications (CEA) service that can allow XML External
Entity Injection (XXE) attacks leading to information
disclosure. This only occurs if CEA is enabled, and by
default this is disabled. (CVE-2014-6166 / PI25310)

- An input validation error exists related to session
input using URL rewriting that can allow cross-site
scripting attacks. (CVE-2014-6167 / PI23819)

- An error exists related to the administrative console
that can allow click-jacking attacks. (CVE-2014-6174 /
PI27152)

See also :

http://www-01.ibm.com/support/docview.wss?uid=swg24039242
http://www-01.ibm.com/support/docview.wss?uid=swg27022958#80010
https://www-304.ibm.com/support/docview.wss?uid=swg21672428
http://www-01.ibm.com/support/docview.wss?uid=swg21687173
https://www-304.ibm.com/support/docview.wss?uid=swg21682767

Solution :

Apply Fix Pack 10 for version 8.0 (8.0.0.10) or later.

Risk factor :

High / CVSS Base Score : 7.1
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:C)
CVSS Temporal Score : 6.2
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false