FreeBSD : PostgreSQL -- multiple buffer overflows and memory issues (3b40bf2c-ad83-11e4-a2b2-0026551a22dc)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing one or more security-related
updates.

Description :

PostgreSQL Project reports :

This update fixes multiple security issues reported in PostgreSQL over
the past few months. All of these issues require prior authentication,
and some require additional conditions, and as such are not considered
generally urgent. However, users should examine the list of security
holes patched below in case they are particularly vulnerable.

- CVE-2015-0241 Buffer overruns in 'to_char' functions.

- CVE-2015-0242 Buffer overrun in replacement printf family of
functions.

- CVE-2015-0243 Memory errors in functions in the pgcrypto extension.

- CVE-2015-0244 An error in extended protocol message reading.

- CVE-2014-8161 Constraint violation errors can cause display of
values in columns which the user would not normally have rights to
see.

See also :

http://www.nessus.org/u?24dc8aac

Solution :

Update the affected packages.

Risk factor :

High

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 81193 ()

Bugtraq ID:

CVE ID: CVE-2014-8161
CVE-2015-0241
CVE-2015-0242
CVE-2015-0243
CVE-2015-0244

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now