IBM WebSphere Application Server 8.5 < Fix Pack 8.5.5.4 Multiple Vulnerabilities (POODLE)

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote application server is affected by multiple vulnerabilities.

Description :

The IBM WebSphere Application Server running on the remote host is
version 8.5 prior to Fix Pack 8.5.5.4. It is, therefore, affected by
the following vulnerabilities :

- Multiple errors exist related to the included IBM HTTP
server that can allow remote code execution or denial
of service. (CVE-2013-5704, CVE-2014-0118,
CVE-2014-0226, CVE-2014-0231 / PI22070)

- An unspecified error exists related to HTTP headers
that can allow information disclosure. (CVE-2014-3021
/ PI08268)

- An error exists related to the way SSL 3.0 handles
padding bytes when decrypting messages encrypted using
block ciphers in cipher block chaining (CBC) mode. A
man-in-the-middle attacker can decrypt a selected byte
of a cipher text in as few as 256 tries if they are able
to force a victim application to repeatedly send the
same data over newly created SSL 3.0 connections. This
is also known as the 'POODLE' issue. (CVE-2014-3566 /
PI28435, PI28436, PI28437)

- An unspecified input validation errors exist related to
the administrative console that can allow cross-site
scripting and cross-site request forgery attacks.
(CVE-2014-4770, CVE-2014-4816 / PI23055)

- An unspecified error exists that can allow OpenID and
OpenID Connect cookies to be spoofed, allowing
information disclosure. (CVE-2014-6164 / PI23430)

- An error exists related to the Communications Enabled
Applications (CEA) service that can allow XML External
Entity Injection (XXE) attacks leading to information
disclosure. This only occurs if CEA is enabled. By
default this is disabled. (CVE-2014-6166 / PI25310)

- An input validation error exists related to session
input using URL rewriting that can allow cross-site
scripting attacks. (CVE-2014-6167 / PI23819)

- An error exists related to the administrative console
that can allow 'click-jacking' attacks. (CVE-2014-6174 /
PI27152)

- An error exists related to deployment descriptor
security constraints and ServletSecurity annotations on
a servlet that can allow privilege escalation. Note that
this issue only affects the 'Liberty Profile'.
(CVE-2014-8890 / PI29911)

See also :

http://www-01.ibm.com/support/docview.wss?uid=swg21690185
http://www-304.ibm.com/support/docview.wss?uid=swg21672428
http://www-01.ibm.com/support/docview.wss?uid=swg24038539
http://www-01.ibm.com/support/docview.wss?uid=swg27036319#8554
http://www-01.ibm.com/support/docview.wss?uid=swg21687173
http://www.zerodayinitiative.com/advisories/ZDI-14-236/
https://www.imperialviolet.org/2014/10/14/poodle.html
https://www.openssl.org/~bodo/ssl-poodle.pdf
https://tools.ietf.org/html/draft-ietf-tls-downgrade-scsv-00

Solution :

Apply Fix Pack 4 for (8.5.5.4) or later.

Note that the following Interim Fixes are available :

- CVE-2013-5704, CVE-2014-0118, CVE-2014-0226, and
CVE-2014-0231 are corrected in IF PI22070.

- CVE-2014-3566 is corrected in various IFs.
Consult IBM document 'swg21687173' for details.

- CVE-2014-4770 and CVE-2014-4816 are corrected in
IF PI23055.

- CVE-2014-6166 is corrected in IF PI25310.

- CVE-2014-8890 is corrected in IF PI29911.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now