This script is Copyright (C) 2014 Tenable Network Security, Inc.
The remote proxy server is affected by a denial of service
According to its banner, the version of Squid running on the remote
host is 3.x prior to 3.3.13 or 3.4.7. It is, therefore, affected by a
denial of service vulnerability.
The flaw exists due to user-supplied input not being properly
validated in request parsing. This allows a remote attacker to
specially craft a request with Range headers with unidentifiable
byte-range values to crash the application.
Note that Nessus has relied only on the version in the proxy server's
banner. The patch released to address the issue does not update the
version in the banner. If the patch has been applied properly, and the
service has been restarted, consider this to be a false positive.
See also :
Upgrade to Squid version 3.3.13 / 3.4.7 or later, or apply the
Risk factor :
Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 4.3
Public Exploit Available : true