Squid 3.x < 3.3.13 / 3.4.7 Request Processing DoS

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote proxy server is affected by a denial of service
vulnerability.

Description :

According to its banner, the version of Squid running on the remote
host is 3.x prior to 3.3.13 or 3.4.7. It is, therefore, affected by a
denial of service vulnerability.

The flaw exists due to user-supplied input not being properly
validated in request parsing. This allows a remote attacker to
specially craft a request with Range headers with unidentifiable
byte-range values to crash the application.

Note that Nessus has relied only on the version in the proxy server's
banner. The patch released to address the issue does not update the
version in the banner. If the patch has been applied properly, and the
service has been restarted, consider this to be a false positive.

See also :

http://www.squid-cache.org/Advisories/SQUID-2014_2.txt
http://www.nessus.org/u?b9a745a4
http://www.nessus.org/u?e2b5e3b7

Solution :

Upgrade to Squid version 3.3.13 / 3.4.7 or later, or apply the
vendor-supplied patch.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Firewalls

Nessus Plugin ID: 77985 ()

Bugtraq ID: 69453

CVE ID: CVE-2014-3609

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now