openSUSE Security Update : libvirt (openSUSE-SU-2013:1550-1)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

libvirt was updated to fix security issues and bugs :

Security issues fixed: CVE-2013-4311: Add support for using 3-arg
pkcheck syntax for process to avoid race conditions.

CVE-2013-4296: Fix a crash (denial of service) in
remoteDispatchDomainMemoryStats

CVE-2013-5651: Fix virBitmapParse to avoid access beyond bounds of
array (denial of service crash).

Also bugs were fixed :

- nwfilter: check for inverted ctdir. bnc#810611

- Add xencommons as 'Wanted' in the systemd libvirtd
service file. bnc#820888

See also :

http://lists.opensuse.org/opensuse-updates/2013-10/msg00024.html
https://bugzilla.novell.com/show_bug.cgi?id=810611
https://bugzilla.novell.com/show_bug.cgi?id=820888
https://bugzilla.novell.com/show_bug.cgi?id=836931
https://bugzilla.novell.com/show_bug.cgi?id=837999
https://bugzilla.novell.com/show_bug.cgi?id=838638

Solution :

Update the affected libvirt packages.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: SuSE Local Security Checks

Nessus Plugin ID: 75168 ()

Bugtraq ID: 62070
62508
62510

CVE ID: CVE-2013-4296
CVE-2013-4311
CVE-2013-5651

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now