Wireshark 1.10.x < 1.10.6 Multiple Vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains an application that is affected by
multiple vulnerabilities.

Description :

The installed version of Wireshark 1.10.x is a version prior to 1.10.6.
It is, therefore, affected by denial of service vulnerabilities in the
following dissectors :

- NFS dissector (CVE-2014-2281)
- M3UA dissector (CVE-2014-2282)
- RLC dissector (CVE-2014-2283)

Additionally, a flaw exists in the 'mpeg_read()' function in the MPEG
file parser, 'wiretap/mpeg.c', where input is not properly sanitized
when handling oversized records. A context-dependent attacker could
cause a buffer overflow with a specially crafted packet trace file,
resulting in a denial of service or potentially arbitrary code
execution. (CVE-2014-2299)

See also :

http://www.wireshark.org/security/wnpa-sec-2014-01.html
http://www.wireshark.org/security/wnpa-sec-2014-02.html
http://www.wireshark.org/security/wnpa-sec-2014-03.html
http://www.wireshark.org/security/wnpa-sec-2014-04.html
http://www.wireshark.org/lists/wireshark-announce/201403/msg00000.html

Solution :

Upgrade to Wireshark version 1.10.6 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 72942 ()

Bugtraq ID: 66066
66068
66070
66072

CVE ID: CVE-2014-2281
CVE-2014-2282
CVE-2014-2283
CVE-2014-2299

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now