ModSecurity < 2.7.0 Multipart Request Parsing Filter Bypass

This script is Copyright (C) 2013-2016 Tenable Network Security, Inc.

Synopsis :

The remote web application firewall may be affected by a security
bypass vulnerability.

Description :

According to its banner, the version of ModSecurity installed on the
remote host is earlier than 2.7.0. It is, therefore, potentially
affected by a security bypass vulnerability. An error exists related
to HTTP POST requests and 'Content-Disposition' headers containing
extra lines that could allow a remote attacker to bypass certain
filters and carry out attacks.

Note that Nessus has not tested for this issue but has instead relied
only on the version in the server's banner.

See also :

Solution :

Upgrade to ModSecurity version 2.7.0 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
CVSS Temporal Score : 5.6
Public Exploit Available : true

Family: Firewalls

Nessus Plugin ID: 67126 ()

Bugtraq ID: 56096

CVE ID: CVE-2012-4528

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now