Google Chrome < 13.0.782.107 Multiple Vulnerabilities

This script is Copyright (C) 2011-2016 Tenable Network Security, Inc.


Synopsis :

The remote host contains a web browser that is affected by multiple
vulnerabilities.

Description :

The version of Google Chrome installed on the remote host is earlier
than 13.0.782.107. As such, it is potentially affected by several
vulnerabilities :

- An unspecified error exists related to extension
installation and confirmation dialogs. (Issue #75821)

- A stale pointer issue exists related to bad line box
tracking and rendering. (Issue #78841)

- A security bypass issue exists related to file download
prompts. (Issue #79266)

- A string handling issue exists related to the HTTP
basic authentication dialog box. (Issue #79426)

- Developer mode NPAPI extensions do not always prompt
a user before installation. (Issue #83273)

- A local, unspecified path disclosure issue exists and
is related to the GL log. (Issue #83841)

- Extensions' homepage URLs are not properly sanitized.
(Issue #84402)

- The browser's speech-input element is not always on the
screen at required times. (Issue #84600)

- A re-entrancy issue related to the GPU lock can cause
the browser to crash. (Issue #84805)

- A buffer overflow exists in the inspector
serialization. (Issue #85559)

- Use-after-free errors exist related to the Pepper
plugin, floating styles, float removal, media
selectors, Skia, resource caching, HTML range handling,
frame loading and display box rendering that can cause
the browser to crash. (Issues #85808, #86502, #87148,
#87227,# 87548, #87729, #87925, #88846, #88889)

- An out-of-bounds write error exists related to the
Internal Components for Unicode (ICU). (Issue #86900)

- Out-of-bounds read errors exist related to text
iteration and Skia paths. (Issue #87298)

- A cross-frame function leak exists. (Issue #87339)

- Access to internal schemes is not properly enforced.
(Issue #87815)

- Client side redirect targets may be leaked to remote
locations. (Issue #88337)

- Const lookups can cause the V8 JavaScript engine to
crash. (Issue #88591)

- Certain PDF files with nested functions can cause the
browser to crash. (Issue #89142)

- The same origin policy is not properly enforced which
can lead to cross-origin script injection and other
cross-origin violations. (Issues #89520, #90222)

See also :

http://www.nessus.org/u?739f0064

Solution :

Upgrade to Google Chrome 13.0.782.107 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false