This script is Copyright (C) 2010-2016 Tenable Network Security, Inc.
The remote proxy server is affected by a denial of service
According to its banner, the version of Squid is 3.x earlier than than
3.1.8, or 3.2.x earlier than 220.127.116.11. Such versions are potentially
affected by a denial of service vulnerability caused by an internal
error in string handling. A remote attacker, exploiting this flaw,
could crash the affected service.
Note that Nessus has relied only on the version in the proxy server's
banner, which is not updated by either of the patches the project has
released to address the issue. If one of those has been applied
properly and the service restarted, consider this to be a false
See also :
Upgrade to Squid version 3.1.8 / 18.104.22.168 or later.
Risk factor :
Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 4.3
Public Exploit Available : true