FreeBSD : apache22 -- several vulnerabilities (e15f2356-9139-11de-8f42-001aa0166822)

This script is Copyright (C) 2009-2016 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing a security-related update.

Description :

Apache ChangeLog reports :

CVE-2009-1891: Fix a potential Denial-of-Service attack against
mod_deflate or other modules.

CVE-2009-1195: Prevent the 'Includes' Option from being enabled in an
.htaccess file if the AllowOverride restrictions do not permit it.

CVE-2009-1890: Fix a potential Denial-of-Service attack against
mod_proxy in a reverse proxy configuration.

CVE-2009-1191: mod_proxy_ajp: Avoid delivering content from a previous
request which failed to send a request body.

CVE-2009-0023, CVE-2009-1955, CVE-2009-1956: The bundled copy of the
APR-util library has been updated, fixing three different security
issues which may affect particular configurations and third-party
modules (was already fixed in 2.2.11_5).

See also :

http://www.nessus.org/u?78847b6f

Solution :

Update the affected package.

Risk factor :

High / CVSS Base Score : 7.8
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C)
Public Exploit Available : true

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 40760 (freebsd_pkg_e15f2356913911de8f42001aa0166822.nasl)

Bugtraq ID:

CVE ID: CVE-2009-0023
CVE-2009-1191
CVE-2009-1195
CVE-2009-1890
CVE-2009-1891
CVE-2009-1955
CVE-2009-1956

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now