openSUSE Security Update : krb5 (krb5-740)

This script is Copyright (C) 2009-2016 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

Clients sending negotiation requests with invalid flags could crash
the kerberos server (CVE-2009-0845).

GSS-API clients could crash when reading from an invalid address space
(CVE-2009-0844).

Invalid length checks could crash applications using the kerberos
ASN.1 parser (CVE-2009-0847).

Under certain circumstances the ASN.1 parser could free an
uninitialized pointer which could crash a kerberos server or even lead
to execution of arbitrary code (CVE-2009-0846).

See also :

https://bugzilla.novell.com/show_bug.cgi?id=485894
https://bugzilla.novell.com/show_bug.cgi?id=486722
https://bugzilla.novell.com/show_bug.cgi?id=486723

Solution :

Update the affected krb5 packages.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: SuSE Local Security Checks

Nessus Plugin ID: 40017 ()

Bugtraq ID:

CVE ID: CVE-2009-0844
CVE-2009-0845
CVE-2009-0846
CVE-2009-0847

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now