CVE-2009-0846

HIGH

Description

The asn1_decode_generaltime function in lib/krb5/asn.1/asn1_decode.c in the ASN.1 GeneralizedTime decoder in MIT Kerberos 5 (aka krb5) before 1.6.4 allows remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code via vectors involving an invalid DER encoding that triggers a free of an uninitialized pointer.

References

http://lists.apple.com/archives/security-announce/2009/May/msg00002.html

http://lists.vmware.com/pipermail/security-announce/2009/000059.html

http://marc.info/?l=bugtraq&m=124896429301168&w=2

http://marc.info/?l=bugtraq&m=130497213107107&w=2

http://rhn.redhat.com/errata/RHSA-2009-0409.html

http://rhn.redhat.com/errata/RHSA-2009-0410.html

http://secunia.com/advisories/34594

http://secunia.com/advisories/34598

http://secunia.com/advisories/34617

http://secunia.com/advisories/34622

http://secunia.com/advisories/34628

http://secunia.com/advisories/34630

http://secunia.com/advisories/34637

http://secunia.com/advisories/34640

http://secunia.com/advisories/34734

http://secunia.com/advisories/35074

http://secunia.com/advisories/35667

http://security.gentoo.org/glsa/glsa-200904-09.xml

http://sunsolve.sun.com/search/document.do?assetkey=1-26-256728-1

http://support.apple.com/kb/HT3549

http://support.avaya.com/elmodocs2/security/ASA-2009-142.htm

http://support.novell.com/docs/Readmes/InfoDocument/patchbuilder/readme_5047180.html

http://support.novell.com/docs/Readmes/InfoDocument/patchbuilder/readme_5047181.html

http://web.mit.edu/kerberos/advisories/MITKRB5-SA-2009-002.txt

http://wiki.rpath.com/Advisories:rPSA-2009-0058

http://wiki.rpath.com/wiki/Advisories:rPSA-2009-0058

http://www.kb.cert.org/vuls/id/662091

http://www.mandriva.com/security/advisories?name=MDVSA-2009:098

http://www.redhat.com/support/errata/RHSA-2009-0408.html

http://www.securityfocus.com/archive/1/502527/100/0/threaded

http://www.securityfocus.com/archive/1/502546/100/0/threaded

http://www.securityfocus.com/archive/1/504683/100/0/threaded

http://www.securityfocus.com/bid/34409

http://www.securitytracker.com/id?1021994

http://www.ubuntu.com/usn/usn-755-1

http://www.us-cert.gov/cas/techalerts/TA09-133A.html

http://www.vmware.com/security/advisories/VMSA-2009-0008.html

http://www.vupen.com/english/advisories/2009/0960

http://www.vupen.com/english/advisories/2009/0976

http://www.vupen.com/english/advisories/2009/1057

http://www.vupen.com/english/advisories/2009/1106

http://www.vupen.com/english/advisories/2009/1297

http://www.vupen.com/english/advisories/2009/2084

http://www.vupen.com/english/advisories/2009/2248

http://www-01.ibm.com/support/docview.wss?uid=swg21396120

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10694

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A5483

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A6301

https://www.redhat.com/archives/fedora-package-announce/2009-April/msg00205.html

https://www.redhat.com/archives/fedora-package-announce/2009-April/msg00206.html

Details

Source: MITRE

Published: 2009-04-09

Updated: 2020-01-21

Type: CWE-20

Risk Information

CVSS v2.0

Base Score: 10

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 10

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:mit:kerberos:5-1.6.3:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:-:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.0:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.0.6:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.1:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.1.1:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.2:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.2:beta1:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.2:beta2:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.2.1:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.2.2:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.2.3:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.2.4:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.2.5:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.2.6:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.2.7:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.2.8:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.3:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.3:alpha1:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.3.1:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.3.2:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.3.3:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.3.4:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.3.5:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.3.6:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.4:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.4.1:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.4.2:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.4.3:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.4.4:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.5:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.5.1:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.5.2:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.5.3:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.6:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.6.1:*:*:*:*:*:*:*

cpe:2.3:a:mit:kerberos_5:1.6.2:*:*:*:*:*:*:*

Tenable Plugins

View all (33 total)

IDNameProductFamilySeverity
89114VMware ESX Multiple Vulnerabilities (VMSA-2009-0008) (remote check)NessusMisc.
critical
79452OracleVM 2.1 : krb5 (OVMSA-2009-0003)NessusOracleVM Local Security Checks
critical
67838Oracle Linux 3 : krb5 (ELSA-2009-0410)NessusOracle Linux Local Security Checks
critical
67837Oracle Linux 4 : krb5 (ELSA-2009-0409)NessusOracle Linux Local Security Checks
critical
67836Oracle Linux 5 : krb5 (ELSA-2009-0408)NessusOracle Linux Local Security Checks
critical
60564Scientific Linux Security Update : krb5 on SL4.x, SL5.x i386/x86_64NessusScientific Linux Local Security Checks
critical
60563Scientific Linux Security Update : krb5 on SL3.x i386/x86_64NessusScientific Linux Local Security Checks
critical
50611VMSA-2010-0016 : VMware ESXi and ESX third-party updates for Service Console and Likewise componentsNessusVMware ESX Local Security Checks
critical
43740CentOS 4 : krb5 (CESA-2009:0409)NessusCentOS Local Security Checks
critical
43739CentOS 5 : krb5 (CESA-2009:0408)NessusCentOS Local Security Checks
critical
41978HP-UX PHSS_39774 : HP-UX Running Kerberos, Remote Denial of Service (DoS), Execution of Arbitrary Code (HPSBUX02421 SSRT090047 rev.2)NessusHP-UX Local Security Checks
critical
41977HP-UX PHSS_39766 : HP-UX Running Kerberos, Remote Denial of Service (DoS), Execution of Arbitrary Code (HPSBUX02421 SSRT090047 rev.2)NessusHP-UX Local Security Checks
critical
41976HP-UX PHSS_39765 : HP-UX Running Kerberos, Remote Denial of Service (DoS), Execution of Arbitrary Code (HPSBUX02421 SSRT090047 rev.2)NessusHP-UX Local Security Checks
critical
41542SuSE 10 Security Update : Kerberos (ZYPP Patch Number 6140)NessusSuSE Local Security Checks
critical
41415SuSE 11 Security Update : Kerberos (SAT Patch Number 738)NessusSuSE Local Security Checks
critical
40393VMSA-2009-0008 : ESX Service Console update for krb5NessusVMware ESX Local Security Checks
critical
40253openSUSE Security Update : krb5 (krb5-740)NessusSuSE Local Security Checks
critical
40017openSUSE Security Update : krb5 (krb5-740)NessusSuSE Local Security Checks
critical
38744Mac OS X 10.5.x < 10.5.7 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
critical
38743Mac OS X Multiple Vulnerabilities (Security Update 2009-002)NessusMacOS X Local Security Checks
critical
38191Mandriva Linux Security Advisory : krb5 (MDVSA-2009:098-1)NessusMandriva Local Security Checks
critical
37819Ubuntu 6.06 LTS / 7.10 / 8.04 LTS / 8.10 : krb5 vulnerabilities (USN-755-1)NessusUbuntu Local Security Checks
critical
36660Fedora 10 : krb5-1.6.3-18.fc10 (2009-2852)NessusFedora Local Security Checks
critical
36137GLSA-200904-09 : MIT Kerberos 5: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
36122openSUSE 10 Security Update : krb5 (krb5-6139)NessusSuSE Local Security Checks
critical
36120Debian DSA-1766-1 : krb5 - several vulnerabilitiesNessusDebian Local Security Checks
critical
36114RHEL 2.1 / 3 : krb5 (RHSA-2009:0410)NessusRed Hat Local Security Checks
critical
36113RHEL 4 : krb5 (RHSA-2009:0409)NessusRed Hat Local Security Checks
critical
36112RHEL 5 : krb5 (RHSA-2009:0408)NessusRed Hat Local Security Checks
critical
36108Fedora 9 : krb5-1.6.3-16.fc9 (2009-2834)NessusFedora Local Security Checks
critical
36107CentOS 3 : krb5 (CESA-2009:0410)NessusCentOS Local Security Checks
critical
5023Mac OS X 10.5 < 10.5.7 Multiple VulnerabilitiesNessus Network MonitorGeneric
critical
800792Mac OS X 10.5 < 10.5.7 Multiple VulnerabilitiesLog Correlation EngineOperating System Detection
high