MySQL < 5.5.6 Multiple Denial of Service

This script is Copyright (C) 2012-2016 Tenable Network Security, Inc.

Synopsis :

The remote database server is vulnerable to multiple denial of
service attacks.

Description :

The version of MySQL installed on the remote host is older than
5.5.6. As such, it reportedly is prone to multiple denial of service
attacks :

- The improper handling of type errors during argument
evaluation in extreme-value functions, e.g., 'LEAST()'
or 'GREATEST()' causes server crashes. (CVE-2010-3833)

- Remote authenticated attackers could crash the server.
(CVE-2010-3834 & CVE-2010-3836)

- The use of 'GROUP_CONCAT()' and 'WITH ROLLUP' caused
server crashes. (CVE-2010-3837)

- The use of an intermediate temporary table and queries
containing calls to 'GREATEST()' or 'LEAST()', having
a list of both numeric and 'LONGBLOB' arguments, caused
server crashes. (CVE-2010-3838)

- The use of nested joins in prepared statements or
stored procedures could result in infinite loops.

See also :

Solution :

Upgrade to MySQL version 5.5.6 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 4.3
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 17836 ()

Bugtraq ID: 43676

CVE ID: CVE-2010-3833

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now