FreeBSD : libsoup -- stack based buffer overflow (8e7bbddd-8338-11e7-867f-b499baebfeaf)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing a security-related update.

Description :

Tobias Mueller reports :

libsoup is susceptible to a stack based buffer overflow attack when
using chunked encoding. Regardless of libsoup being used as a server
or client.

See also :

http://seclists.org/oss-sec/2017/q3/304
http://www.nessus.org/u?f4c5c58f

Solution :

Update the affected package.

Risk factor :

High

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 102553 ()

Bugtraq ID:

CVE ID: CVE-2017-2885

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now