This script is Copyright (C) 2017 Tenable Network Security, Inc.
The remote proxy server is affected by multiple vulnerabilities.
According to its banner, the version of Squid running on the remote
host is 3.5.x prior to 3.5.23 or 4.x prior to 4.0.17. It is, therefore,
affected by multiple vulnerabilities :
- A flaw exists in client_side_reply.cc due to incorrect
HTTP conditional request handling. An unauthenticated,
remote attacker can exploit this to disclose sensitive
information regarding the browser sessions of other
- A flaw exists in client_side_reply.cc due to improper
HTTP request header comparison, which results in the
Collapsed Forwarding feature incorrectly identifying
some private responses as being suitable for delivery to
multiple clients. An unauthenticated, remote attacker
can exploit this to disclose sensitive information
regarding the browser sessions of other clients. Note
that this issue only affects Squid if it is configured
to use the Collapsed Forwarding feature.
Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.
Furthermore, the patch released to address these vulnerabilities does
not cause the version given in the banner to be updated. If the patch
has been applied properly and the service has been restarted, then
consider this to be a false positive.
See also :
Upgrade to Squid version 3.5.23 / 4.0.17 or later. Alternatively,
apply the vendor-supplied patch.
Risk factor :
Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 3.7
Public Exploit Available : false