CVE-2021-21704

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

In PHP versions 7.3.x below 7.3.29, 7.4.x below 7.4.21 and 8.0.x below 8.0.8, when using Firebird PDO driver extension, a malicious database server could cause crashes in various database functions, such as getAttribute(), execute(), fetch() and others by returning invalid response data that is not parsed correctly by the driver. This can result in crashes, denial of service or potentially memory corruption.

References

https://bugs.php.net/bug.php?id=76450

https://bugs.php.net/bug.php?id=76452

https://bugs.php.net/bug.php?id=76449

https://bugs.php.net/bug.php?id=76448

https://security.netapp.com/advisory/ntap-20211029-0006/

Details

Source: MITRE

Published: 2021-10-04

Updated: 2021-11-03

Type: CWE-119

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 5.9

Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 2.2

Severity: MEDIUM

Tenable Plugins

View all (17 total)

IDNameProductFamilySeverity
153169Amazon Linux AMI : php73 (ALAS-2021-1532)NessusAmazon Linux Local Security Checks
medium
152986Tenable SecurityCenter < 5.19.0 Multiple Vulnerabilities (TNS-2021-14)NessusMisc.
high
152727openSUSE 15 Security Update : php7 (openSUSE-SU-2021:2795-1)NessusSuSE Local Security Checks
critical
152717SUSE SLES15 Security Update : php7 (SUSE-SU-2021:2795-1)NessusSuSE Local Security Checks
critical
152466openSUSE 15 Security Update : php7 (openSUSE-SU-2021:1130-1)NessusSuSE Local Security Checks
critical
152269SUSE SLED12 / SLES12 Security Update : php72 (SUSE-SU-2021:2638-1)NessusSuSE Local Security Checks
critical
152259openSUSE 15 Security Update : php7 (openSUSE-SU-2021:2637-1)NessusSuSE Local Security Checks
critical
152254SUSE SLED12 / SLES12 Security Update : php74 (SUSE-SU-2021:2636-1)NessusSuSE Local Security Checks
critical
152243SUSE SLES15 Security Update : php7 (SUSE-SU-2021:2637-1)NessusSuSE Local Security Checks
critical
151985Tenable.sc < 5.19.0 Multiple Vulnerabilities (TNS-2021-14) (deprecated)NessusMisc.
high
151676Debian DLA-2708-1 : php7.0 - LTS security updateNessusDebian Local Security Checks
critical
151583Ubuntu 16.04 LTS : PHP vulnerabilities (USN-5006-2)NessusUbuntu Local Security Checks
medium
151444Ubuntu 18.04 LTS / 20.04 LTS / 20.10 / 21.04 : PHP vulnerabilities (USN-5006-1)NessusUbuntu Local Security Checks
medium
112883PHP 7.3.x < 7.3.29 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
medium
112882PHP 7.4.x < 7.4.21 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
medium
112881PHP 8.x < 8.0.8 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
medium
151423Debian DSA-4935-1 : php7.3 - security updateNessusDebian Local Security Checks
critical