CVE-2020-28021

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Exim 4 before 4.94.2 has Improper Neutralization of Line Delimiters. An authenticated remote SMTP client can insert newline characters into a spool file (which indirectly leads to remote code execution as root) via AUTH= in a MAIL FROM command.

References

https://www.exim.org/static/doc/security/CVE-2020-qualys/CVE-2020-28021-MAUTH.txt

Details

Source: MITRE

Published: 2021-05-06

Updated: 2021-05-10

Risk Information

CVSS v2

Base Score: 9

Vector: AV:N/AC:L/Au:S/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 8

Severity: HIGH

CVSS v3

Base Score: 8.8

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:exim:exim:*:*:*:*:*:*:*:*

Tenable Plugins

View all (7 total)

IDNameProductFamilySeverity
149614openSUSE Security Update : exim (openSUSE-2021-677) (Stack Clash)NessusSuSE Local Security Checks
critical
149430Amazon Linux AMI : exim (ALAS-2021-1497)NessusAmazon Linux Local Security Checks
high
149345Debian DLA-2650-1 : exim4 security updateNessusDebian Local Security Checks
critical
149277GLSA-202105-01 : Exim: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
149275Debian DSA-4912-1 : exim4 - security updateNessusDebian Local Security Checks
critical
149260Exim < 4.94.2 Multiple Vulnerabilities (21Nails)NessusSMTP problems
critical
149253Ubuntu 18.04 LTS / 20.04 LTS / 20.10 / 21.04 : Exim vulnerabilities (USN-4934-1)NessusUbuntu Local Security Checks
critical