CVE-2020-28011

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Exim 4 before 4.94.2 allows Heap-based Buffer Overflow in queue_run via two sender options: -R and -S. This may cause privilege escalation from exim to root.

References

https://www.exim.org/static/doc/security/CVE-2020-qualys/CVE-2020-28011-SPRSS.txt

Details

Source: MITRE

Published: 2021-05-06

Updated: 2021-05-10

Type: CWE-787

Risk Information

CVSS v2

Base Score: 7.2

Vector: AV:L/AC:L/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 3.9

Severity: HIGH

CVSS v3

Base Score: 7.8

Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 1.8

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:exim:exim:*:*:*:*:*:*:*:*

Tenable Plugins

View all (7 total)

IDNameProductFamilySeverity
149614openSUSE Security Update : exim (openSUSE-2021-677) (Stack Clash)NessusSuSE Local Security Checks
critical
149345Debian DLA-2650-1 : exim4 security updateNessusDebian Local Security Checks
critical
149323Ubuntu 16.04 LTS : Exim vulnerabilities (USN-4934-2)NessusUbuntu Local Security Checks
critical
149277GLSA-202105-01 : Exim: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
149275Debian DSA-4912-1 : exim4 - security updateNessusDebian Local Security Checks
critical
149260Exim < 4.94.2 Multiple Vulnerabilities (21Nails)NessusSMTP problems
critical
149253Ubuntu 18.04 LTS / 20.04 LTS / 20.10 / 21.04 : Exim vulnerabilities (USN-4934-1)NessusUbuntu Local Security Checks
critical