CVE-2020-11994

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Server-Side Template Injection and arbitrary file disclosure on Camel templating components

References

https://lists.apache.org/thread.html/[email protected]%3Cannounce.tomcat.apache.org%3E

https://www.oracle.com/security-alerts/cpujan2021.html

https://www.oracle.com/security-alerts/cpuApr2021.html

https://www.oracle.com/security-alerts/cpuoct2021.html

Details

Source: MITRE

Published: 2020-07-08

Updated: 2021-10-20

Type: CWE-74

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:apache:camel:*:*:*:*:*:*:*:* versions from 2.22.0 to 2.22.5 (inclusive)

cpe:2.3:a:apache:camel:*:*:*:*:*:*:*:* versions from 2.23.0 to 2.23.4 (inclusive)

cpe:2.3:a:apache:camel:*:*:*:*:*:*:*:* versions from 2.24.0 to 2.24.3 (inclusive)

cpe:2.3:a:apache:camel:2.25.0:*:*:*:*:*:*:*

cpe:2.3:a:apache:camel:2.25.1:*:*:*:*:*:*:*

cpe:2.3:a:apache:camel:*:*:*:*:*:*:*:* versions from 3.0.0 to 3.3.0 (inclusive)

Tenable Plugins

View all (1 total)

IDNameProductFamilySeverity
148895Oracle Enterprise Manager Cloud Control (Apr 2021 CPU)NessusMisc.
high