CVE-2019-2697

HIGH
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Vulnerability in the Java SE component of Oracle Java SE (subcomponent: 2D). Supported versions that are affected are Java SE: 7u211 and 8u202. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE. Successful attacks of this vulnerability can result in takeover of Java SE. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets (in Java SE 8), that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability does not apply to Java deployments, typically in servers, that load and run only trusted code (e.g., code installed by an administrator). CVSS 3.0 Base Score 8.1 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H).

References

http://www.oracle.com/technetwork/security-advisory/cpuapr2019-5072813.html

https://access.redhat.com/errata/RHSA-2019:1163

https://access.redhat.com/errata/RHSA-2019:1164

https://access.redhat.com/errata/RHSA-2019:1165

https://access.redhat.com/errata/RHSA-2019:1166

https://access.redhat.com/errata/RHSA-2019:1238

https://access.redhat.com/errata/RHSA-2019:1325

https://security.gentoo.org/glsa/201908-10

https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbst03959en_us

https://usn.ubuntu.com/3975-1/

Details

Source: MITRE

Published: 2019-04-23

Updated: 2020-09-08

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.2

Severity: HIGH

Tenable Plugins

View all (18 total)

IDNameProductFamilySeverity
127959GLSA-201908-10 : Oracle JDK/JRE: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
126924AIX Java Advisory : java_apr2019_advisory.asc (April 2019 CPU)NessusAIX Local Security Checks
high
126336SUSE SLED15 / SLES15 Security Update : java-1_8_0-ibm (SUSE-SU-2019:1308-2)NessusSuSE Local Security Checks
high
126167SUSE SLES12 Security Update : java-1_8_0-ibm (SUSE-SU-2019:1644-1)NessusSuSE Local Security Checks
high
125900Amazon Linux 2 : java-11-amazon-corretto (ALAS-2019-1228)NessusAmazon Linux Local Security Checks
high
125756RHEL 6 : java-1.8.0-ibm (RHSA-2019:1325)NessusRed Hat Local Security Checks
high
125461SUSE SLES12 Security Update : java-1_7_1-ibm (SUSE-SU-2019:1345-1)NessusSuSE Local Security Checks
high
125336SUSE SLES11 Security Update : java-1_7_1-ibm (SUSE-SU-2019:14059-1)NessusSuSE Local Security Checks
high
125335SUSE SLES15 Security Update : java-1_8_0-ibm (SUSE-SU-2019:1308-1)NessusSuSE Local Security Checks
high
125239RHEL 8 : java-1.8.0-ibm (RHSA-2019:1238)NessusRed Hat Local Security Checks
critical
125028Ubuntu 16.04 LTS / 18.04 LTS / 18.10 / 19.04 : OpenJDK vulnerabilities (USN-3975-1)NessusUbuntu Local Security Checks
high
125015RHEL 7 : java-1.7.1-ibm (RHSA-2019:1166)NessusRed Hat Local Security Checks
high
125014RHEL 6 : java-1.7.1-ibm (RHSA-2019:1165)NessusRed Hat Local Security Checks
high
125013RHEL 7 : java-1.8.0-ibm (RHSA-2019:1164)NessusRed Hat Local Security Checks
high
125012RHEL 6 : java-1.8.0-ibm (RHSA-2019:1163)NessusRed Hat Local Security Checks
high
700660Oracle Java SE 7 < Update 221 / 8 < Update 211 / 11 < Update 3 / 12 < Update 1 Multiple Vulnerabilities (Apr 2019 CPU)Nessus Network MonitorWeb Clients
critical
124198Oracle Java SE 1.7.0_221 / 1.8.0_211 / 1.11.0_3 / 1.12.0_1 Multiple Vulnerabilities (Apr 2019 CPU)NessusWindows
critical
124197Oracle Java SE 1.7.0_221 / 1.8.0_211 / 1.11.0_3 / 1.12.0_1 Multiple Vulnerabilities (Apr 2019 CPU) (Unix)NessusMisc.
critical