CVE-2019-1579

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Remote Code Execution in PAN-OS 7.1.18 and earlier, PAN-OS 8.0.11-h1 and earlier, and PAN-OS 8.1.2 and earlier with GlobalProtect Portal or GlobalProtect Gateway Interface enabled may allow an unauthenticated remote attacker to execute arbitrary code.

References

http://www.securityfocus.com/bid/109310

https://devco.re/blog/2019/07/17/attacking-ssl-vpn-part-1-PreAuth-RCE-on-Palo-Alto-GlobalProtect-with-Uber-as-case-study/

https://psirt.global.sonicwall.com/vuln-detail/SNWLID-2019-0010

https://security.paloaltonetworks.com/CVE-2019-1579

Details

Source: MITRE

Published: 2019-07-19

Updated: 2020-08-24

Type: CWE-134

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.2

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:o:paloaltonetworks:pan-os:*:*:*:*:*:*:*:* versions up to 7.1.18 (inclusive)

cpe:2.3:o:paloaltonetworks:pan-os:*:*:*:*:*:*:*:* versions from 8.0.0 to 8.0.11 (inclusive)

cpe:2.3:o:paloaltonetworks:pan-os:*:*:*:*:*:*:*:* versions from 8.1.0 to 8.1.2 (inclusive)

Tenable Plugins

View all (1 total)

IDNameProductFamilySeverity
126787Palo Alto Networks PAN-OS 7.1.x < 7.1.19 / 8.0.x < 8.0.12 / 8.1.x < 8.1.3 VulnerabilityNessusPalo Alto Local Security Checks
high