CVE-2013-2017

high

Description

The veth (aka virtual Ethernet) driver in the Linux kernel before 2.6.34 does not properly manage skbs during congestion, which allows remote attackers to cause a denial of service (system crash) by leveraging lack of skb consumption in conjunction with a double-free error.

References

http://ftp.osuosl.org/pub/linux/kernel/v2.6/ChangeLog-2.6.34

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=6ec82562ffc6f297d0de36d65776cff8e5704867

http://www.openwall.com/lists/oss-security/2013/04/29/10

https://bugzilla.redhat.com/show_bug.cgi?id=957705

https://github.com/torvalds/linux/commit/6ec82562ffc6f297d0de36d65776cff8e5704867

https://support.f5.com/csp/article/K39655464

Details

Source: MITRE

Published: 2013-05-03

Updated: 2019-05-23

Type: CWE-399

Risk Information

CVSS v2

Base Score: 7.8

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:C

Impact Score: 6.9

Exploitability Score: 10

Severity: HIGH