MySQL 5.5.x < 5.5.37 MySQL Multiple Vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote database server is potentially affected by multiple
vulnerabilities.

Description :

The version of MySQL installed on the remote host is version 5.5.x
prior to 5.5.37. It is, therefore, potentially affected by an error in
file 'client/mysql.cc' and the following components :

- Client
- Options
- Performance Schema
- RBR

See also :

http://www.nessus.org/u?ef1fc2a6
http://bazaar.launchpad.net/~mysql/mysql-server/5.5/revision/4601
http://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-37.html

Solution :

Upgrade to MySQL 5.5.37 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.9
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 73318 ()

Bugtraq ID: 66850
66858
66890
66896

CVE ID: CVE-2014-2430
CVE-2014-2431
CVE-2014-2436
CVE-2014-2440