Squid 3.1.x < 3.3.12 / 3.4.4 HTTPS Request Handling DoS

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote proxy server is affected by a denial of service
vulnerability.

Description :

According to its banner, the version of Squid running on the remote
host is 3.x prior to 3.3.12 or 3.4.4 and is, therefore, affected by a
denial of service vulnerability.

A flaw exists in SSL-Bump in regards to the state management when
processing range requests. A remote attacker can cause the server to
crash with specially crafted HTTPS requests.

Note that Nessus has relied only on the version in the proxy server's
banner, which is not updated by the patch the project has released to
address the issue. If this patch has been applied properly and the
service has been restarted, consider this to be a false positive.

See also :

http://www.squid-cache.org/Advisories/SQUID-2014_1.txt
http://www.nessus.org/u?bf7922a2
http://www.nessus.org/u?13763a56

Solution :

Either upgrade to Squid version 3.3.12 / 3.4.4 or later, or apply the
vendor-supplied patch.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Firewalls

Nessus Plugin ID: 73131 ()

Bugtraq ID: 66112

CVE ID: CVE-2014-0128