ModSecurity < 2.7.0 Multipart Request Parsing Filter Bypass

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote web application firewall may be affected by a security
bypass vulnerability.

Description :

According to its banner, the version of ModSecurity installed on the
remote host is earlier than 2.7.0. It is, therefore, potentially
affected by a security bypass vulnerability. An error exists related
to HTTP POST requests and 'Content-Disposition' headers containing
extra lines that could allow a remote attacker to bypass certain
filters and carry out attacks.

Note that Nessus has not tested for this issue but has instead relied
only on the version in the server's banner.

See also :

http://www.nessus.org/u?2993ca56
https://github.com/SpiderLabs/ModSecurity/blob/master/CHANGES

Solution :

Upgrade to ModSecurity version 2.7.0 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.6
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Firewalls

Nessus Plugin ID: 67126 ()

Bugtraq ID: 56096

CVE ID: CVE-2012-4528