phpMyAdmin 3.5.x < 3.5.8 tbl_gis_visualization.php Multiple XSS

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server hosts a PHP application that is affected by
multiple cross-site scripting vulnerabilities.

Description :

According to its self-identified version number, the phpMyAdmin 3.5.x
install hosted on the remote web server is earlier than 3.5.8 and is,
therefore, affected by multiple cross-site scripting vulnerabilities.
The flaw exists in the 'visualizationSettings[width]' and
'visualizationSettings[height]' parameters of the
'tls_gis_visualization.php' script. An unauthenticated, remote
attacker, exploiting this flaw, could execute arbitrary script code in a
user's browser.

See also :

http://www.waraxe.us/advisory-102.html

Solution :

Either upgrade to phpMyAdmin 3.5.8 or later, or apply the patches from
the referenced link.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 66203 ()

Bugtraq ID: 58962

CVE ID: CVE-2013-1937