MySQL 5.5 < 5.5.31 Multiple Vulnerabilities

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote database server may be affected by multiple
vulnerabilities.

Description :

The version of MySQL 5.5 installed on the remote host is earlier than
5.5.31 and is, therefore, potentially affected by vulnerabilities in the
following components :

- Data Manipulation Language
- Information Schema
- InnoDB
- Prepared Statements
- Server
- Server Install
- Server Locking
- Server Options
- Server Optimizer
- Server Partition
- Server Privileges
- Server Replication
- Server XML
- Stored Procedure

See also :

http://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-31.html
http://www.nessus.org/u?27b48f62
http://www.nessus.org/u?96e69d66

Solution :

Upgrade to MySQL version 5.5.31 or later.

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)
CVSS Temporal Score : 4.8
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false