MySQL 5.5 < 5.5.30 yaSSL Buffer Overflow

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by a buffer overflow
vulnerability.

Description :

The version of MySQL 5.5 installed on the remote host is earlier than
5.5.30 and is, therefore, affected a buffer overflow related to 'yaSSL'.
This error could possibly allow arbitrary code execution.

See also :

http://www.zerodayinitiative.com/advisories/ZDI-13-251/
http://dev.mysql.com/doc/refman/5.5/en/news-5-5-30.html
http://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-30.html
https://blogs.oracle.com/sunsecurity/entry/cve_2012_0553_buffer_overflow
http://www.nessus.org/u?ef866628

Solution :

Upgrade to MySQL version 5.5.30 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 65734 ()

Bugtraq ID: 58595

CVE ID: CVE-2013-1492