MariaDB 5.5 < 5.5.28 Multiple Vulnerabilities

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote database server has multiple vulnerabilities.

Description :

The version of MariaDB 5.5 installed on the remote host is earlier than
5.5.28 and is, therefore, potentially affected by vulnerabilities in the
following components :

- GIS Extension
- Server
- Server Installation
- Server Optimizer
- yaSSL

See also :

https://kb.askmonty.org/en/mariadb-5528-release-notes/
http://dev.mysql.com/doc/refman/5.5/en/news-5-5-28.html

Solution :

Upgrade to MariaDB 5.5.28 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 65731 ()

Bugtraq ID: 56003
56005
56027
57411
58594

CVE ID: CVE-2012-0553
CVE-2012-3160
CVE-2012-3177
CVE-2012-3180
CVE-2012-5060