Squid 3.x < 3.2.9 / 3.3.3 strHdrAcptLangGetItem Malformed Accept-Language Denial of Service

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote proxy server is affected by a denial of service
vulnerability.

Description :

According to its banner, the version of Squid running on the remote
host is 3.2.x prior to 3.2.9 or 3.3.x prior to 3.3.3 and is, therefore,
affected by a denial of service vulnerability. An error exists in the
function 'strHdrAcptLangGetItem' in the file 'errorpage.cc' that could
allow certain 'Accept-Language' HTTP headers to cause a denial of
service condition.

Note that Nessus has relied only on the version in the proxy server's
banner, which is not updated by the patch the project has released to
address the issue. If this patch has been applied properly and the
service has been restarted, consider this to be a false positive.

See also :

http://www.squid-cache.org/Advisories/SQUID-2013_1.txt
http://seclists.org/bugtraq/2013/Mar/68
http://www.nessus.org/u?bd6b7229

Solution :

Either upgrade to Squid version 3.2.9 / 3.3.3 or later, or apply the
vendor-supplied patch.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Firewalls

Nessus Plugin ID: 65601 ()

Bugtraq ID: 58316

CVE ID: CVE-2013-1839