Apache CouchDB < 1.0.4 / 1.1.2 / 1.2.1 Multiple Vulnerabilities

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote database server is potentially affected by multiple
vulnerabilities.

Description :

According to its banner, the version of CouchDB running on the remote
host is earlier than 1.0.4, 1.1.x earlier than 1.1.2 or 1.2.x earlier
than 1.2.1. It is, therefore, potentially affected by the following
vulnerabilities :

- An unspecified error exists in the included MochiWeb
HTTP library that can allow access to arbitrary files
via directory traversal attacks. Note that reportedly,
this issue only affects installs on Windows hosts.
(CVE-2012-5641)

- An error related to JSONP callbacks can allow an
unspecified cross-site scripting attack. (CVE-2012-5649)

- An input validation error exists related to unspecified
query parameters and the Futon UI that can allow DOM-
based cross-site scripting attacks. (CVE-2012-5650)

Note that Nessus did not actually test for these flaws but instead, has
relied on the version in CouchDB's banner.

See also :

http://www.securityfocus.com/archive/1/525297/30/0/threaded
http://www.securityfocus.com/archive/1/525299/30/0/threaded
http://www.securityfocus.com/archive/1/525300/30/0/threaded

Solution :

Upgrade to CouchDB 1.0.4 / 1.1.2 / 1.2.1 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.2
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 63642 ()

Bugtraq ID: 57313
57314
57321

CVE ID: CVE-2012-5641
CVE-2012-5649
CVE-2012-5650