PostgreSQL 8.3 < 8.3.18 Multiple Vulnerabilities

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.

Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

The version of PostgreSQL installed on the remote host is 8.3.x prior
to 8.3.18, and is, therefore, potentially affected by multiple
vulnerabilities :

- Permissions on a function called by a trigger are not
properly checked. (CVE-2012-0866)

- Line breaks in object names can be exploited to execute
arbitrary SQL commands when reloading a pg_dump file.

See also :

Solution :

Upgrade to PostgreSQL 8.3.18 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
CVSS Temporal Score : 5.0
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 63355 ()

Bugtraq ID: 52188

CVE ID: CVE-2012-0866