PostgreSQL 7.4 < 7.4.27 / 8.0 < 8.0.23 / 8.1 < 8.1.19 / 8.2 < 8.2.15 / 8.3 < 8.3.9 / 8.4 < 8.4.2 Multiple Vulnerabilities

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

The version of PostgreSQL installed on the remote host is 7.4 prior to
7.4.27, 8.0 prior to 8.0.23, 8.1 prior to 8.1.19, 8.2 prior to 8.2.15,
8.3 prior to 8.3.9 or 8.4 prior to 8.4.2. As such, it is potentially
affected by multiple vulnerabilities :

- NULL bytes in SSL Certificates can be used to falsify
client or server authentication. (CVE-2009-4034)

- Privilege escalation is possible via changing session
state in an index function. (CVE-2009-4136)

See also :

http://www.postgresql.org/about/news/1170/
http://www.postgresql.org/docs/7.4/static/release-7-4-27.html
http://www.postgresql.org/docs/8.0/static/release-8-0-23.html
http://www.postgresql.org/docs/8.1/static/release-8-1-19.html
http://www.postgresql.org/docs/8.2/static/release-8-2-15.html
http://www.postgresql.org/docs/8.3/static/release-8-3-9.html
http://www.postgresql.org/docs/8.4/static/release-8-4-2.html

Solution :

Upgrade to PostgreSQL 7.4.27 / 8.0.23 / 8.1.19 / 8.2.15 / 8.3.9 / 8.4.2
or later.

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)
CVSS Temporal Score : 5.4
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 63348 ()

Bugtraq ID: 37333
37334

CVE ID: CVE-2009-4034
CVE-2009-4136