MySQL Community Server 5.1 < 5.1.52 Multiple Vulnerabilities

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

The version of MySQL Community Server 5.1 installed on the remote host
is earlier than 5.1.52 and thus potentially affected by multiple
vulnerabilities:

- An error exists in the handling of 'EXPLAIN' for a
'SELECT' statement from a derived table which can cause
the server to crash. (54488)

- An error exists in the handling of 'EXPLAIN EXTENDED'
when used in some prepared statements, which can cause
the server to crash. (54494)

- The server does not check the type of values assigned
to items of type 'GeometryCollection'. Such assignments
can cause the server to crash. (55531)

See also :

http://bugs.mysql.com/bug.php?id=54488
http://bugs.mysql.com/bug.php?id=54494
http://bugs.mysql.com/bug.php?id=55531
http://dev.mysql.com/doc/refman/5.1/en/news-5-1-52.html

Solution :

Upgrade to MySQL Community Server 5.1.52 or later.

Risk factor :

Medium / CVSS Base Score : 4.0
(CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P)
CVSS Temporal Score : 3.3
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 50527 ()

Bugtraq ID: 47871

CVE ID: