Apache Tomcat 5.x < 5.5.21 Multiple Vulnerabilities

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server may be affected by multiple vulnerabilities.

Description :

According to its self-reported version number, the instance of Apache
Tomcat 5.x listening on the remote host is earlier than 5.5.21 and,
therefore, may be affected by one or more of the following
vulnerabilities :

- The remote Apache Tomcat install is vulnerable to a
cross-site scripting attack. The client supplied
Accept-Language headers are not validated which allows
an attacker to use a specially crafted URL to inject
arbitrary HTML and script code into the user's browser.
(CVE-2007-1358)

- If the remote Apache Tomcat install is configured to use
the SingleSignOn Valve, the JSESSIONIDSSO cookie does
not have the 'secure' attribute set if authentication
takes place over HTTPS. This allows the JSESSIONIDSSO
cookie to be sent to the same server when HTTP content
is requested. (CVE-2008-0128)

- The remote Apache Tomcat install is affected by an
information disclosure vulnerability. The doRead method
fails to return the proper error code for certain error
conditions, which can cause POST content to be sent to
different, and improper, requests. (CVE-2008-4308)

Note that Nessus did not actually test for the flaws but instead has
relied on the version in Tomcat's banner or error page so this may be
a false positive.

See also :

http://issues.apache.org/bugzilla/show_bug.cgi?id=41217
http://tomcat.apache.org/security-5.html#Fixed_in_Apache_Tomcat_5.5.21

Solution :

Update Apache Tomcat to version 5.5.21 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 4.1
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 46868 ()

Bugtraq ID: 24524
27365
33913

CVE ID: CVE-2007-1358
CVE-2008-0128
CVE-2008-4308