MySQL < 6.0.9-alpha / 5.5.3 Access Control Weakness

This script is Copyright (C) 2012-2013 Tenable Network Security, Inc.


Synopsis :

Access restrictions can be bypassed on the remote database server.

Description :

The version of MySQL installed on the remote host is older than
6.0.9-alpha / 5.5.3. As such, it reportedly allows
a remote attacker to bypass access restrictions when the data
directory contains a symbolic link to a different file system.

See also :

http://marc.info/?l=oss-security&m=125908040022018&w
http://lists.mysql.com/commits/59711
http://bugs.mysql.com/bug.php?id=39277

Solution :

Upgrade to MySQL version 6.0.9-alpha / 5.5.3 or later.

Risk factor :

Medium / CVSS Base Score : 6.0
(CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P)
CVSS Temporal Score : 4.4
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 17837 ()

Bugtraq ID: 38043

CVE ID: CVE-2008-7247