MySQL libmysqlclient Prepared Statements API Overflow

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by a remote code execution
vulnerability.

Description :

You are running a version of MySQL 4.1.x, which is older than version 4.1.5.

There is a flaw in the remote version of this software that could allow
an attacker to crash the affected service, thus denying access to
legitimate users.

See also :

http://bugs.mysql.com/bug.php?id=5194

Solution :

Upgrade to MySQL 4.1.5 or later, as this reportedly fixes the issue.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.7
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 14831 ()

Bugtraq ID: 11261

CVE ID: CVE-2004-2149