Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Apache ActiveMQ 5.x < 5.11.4, 5.12.x < 5.12.3, or 5.13.x < 5.13.2 XSS

Medium

Synopsis

The remote host is running a web application that is affected by a Cross-Site Scripting (XSS) attack vector.

Description

Versions of Apache ActiveMQ 5.x prior to 5.11.4, 5.12.3, or 5.13.2 are affected by a flaw that is due to missing 'X-Frame-Options' headers in HTTP responses. This may potentially allow a context-dependent attacker to conduct a clickjacking attack.

Solution

Upgrade to ActiveMQ 5.13.2 or later. If version 5.13.x cannot be obtained, versions 5.12.3 and 5.11.4 have also been patched for this issue.