Apache ActiveMQ 5.11.x < 5.11.4 / 5.12.x < 5.12.3 / 5.13.x < 5.13.1 Web Console Multiple XSS

medium Nessus Plugin ID 90024


The remote host is running a web application that is affected by multiple cross-site scripting vulnerabilities.


The version of Apache ActiveMQ running on the remote host is 5.11.x prior to 5.11.4, 5.12.x prior to 5.12.3, or 5.x prior to 5.13.1. It is, therefore, affected by multiple cross-site scripting vulnerabilities in the web-based administration console due to improper validation of user-supplied input. A remote attacker can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session.


Upgrade to Apache ActiveMQ version 5.11.4 / 5.12.3 / 5.13.1 or later.

See Also


Plugin Details

Severity: Medium

ID: 90024

File Name: activemq_5_13_1.nasl

Version: 1.12

Type: combined

Agent: unix

Family: CGI abuses

Published: 3/18/2016

Updated: 6/6/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent, Nessus

Enable CGI Scanning: true

Risk Information


Risk Factor: Low

Score: 3.0


Risk Factor: Low

Base Score: 3.5

Temporal Score: 2.9

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N

CVSS Score Source: CVE-2016-0782


Risk Factor: Medium

Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:activemq

Required KB Items: installed_sw/Apache ActiveMQ

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 3/7/2016

Vulnerability Publication Date: 3/10/2016

Reference Information

CVE: CVE-2016-0782