Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

OpenSSH < 7.2p2 X11Forwarding xauth Command Injection

Medium

Synopsis

The remote SSH server may be affected by a command injection vulnerability.

Description

OpenSSH contains a flaw when X11Forwarding is enabled that is due to the system failing to sanitize X11 authentication credentials allowing an authenticated remote attacker to inject arbitrary xauth commands.

Note: PVS has solely relied on the banner of the SSH client to perform this check. Any backported patches or workarounds such as recompiling or edited configurations are not observable through the banner.

Solution

Upgrade to OpenSSH version 7.2p2 or later.