OpenSSH < 7.2p2 X11Forwarding xauth Command Injection

Medium Nessus Plugin ID 90023


The SSH server running on the remote host is affected by a security bypass vulnerability.


According to its banner, the version of OpenSSH running on the remote host is prior to 7.2p2. It is, therefore, affected by a security bypass vulnerability due to improper sanitization of X11 authentication credentials. An authenticated, remote attacker can exploit this, via crafted credentials, to inject arbitrary xauth commands, resulting in gaining read and write access to arbitrary files, connecting to local ports, or performing further attacks on xauth itself. Note that exploiting this vulnerability requires X11Forwarding to have been enabled.


Upgrade to OpenSSH version 7.2p2 or later.

See Also

Plugin Details

Severity: Medium

ID: 90023

File Name: openssh_72p2.nasl

Version: $Revision: 1.5 $

Type: remote

Family: Misc.

Published: 2016/03/18

Modified: 2018/02/20

Dependencies: 10267

Risk Information

Risk Factor: Medium


Base Score: 5.5

Temporal Score: 4.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/03/10

Vulnerability Publication Date: 2016/03/10

Reference Information

CVE: CVE-2016-3115

OSVDB: 135714

EDB-ID: 39569