Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

MariaDB Server 5.4.x < 5.4.46 / 10.0.x < 10.0.22 Multiple DoS Vulnerabilities

Medium

Synopsis

The remote database server is affected by multiple Denial of Service (DoS) attack vectors.

Description

MariaDB is a community-developed fork of the MySQL relational database. The version of MariaDB installed on the remote host is 5.4.x earlier than 5.4.46 or 10.0.x earlier than 10.0.22, and is therefore affected by the following denial of service vulnerabilities :

- A flaw exists in the 'Item_subselect::fix_fields()' function in the file 'item_cmpfunc.cc' that is triggered when handling SemiJoin. This may allow an authenticated attacker to cause a denial of service. (OSVDB 128971) - A flaw exists in the 'Item_in_optimized()' function in the file 'item_subselect.cc' that is triggered when referencing subselects. This may allow an authenticated attacker to crash the server. (OSVDB 128974) - An uninitialized memory access flaw exists in the 'item_in_optimizer()' function during subselect preparation in the file 'opt_subselect.cc'. This may allow an authenticated attacker to crash the server. (OSVDB 128976)

Solution

Upgrade to version 10.0.22 or later. If version 10.0.x cannot be obtained, version 5.4.46 has also been patched for these issues.